Microsoft's Xbox 360 Incompatible with Apple's Airport Extreme 802.11nS

Two can play the incompatibility game. It looks like Microsoft's getting back at Apple's "don't get Vista if you want to use iTunes" by telling Xbox 360 users not to get the new Airport Extreme because it's incompatible with their game console.

Apparently the 360's having trouble either with WPA/WPA2 security or routers with N-support, as a few Linksys and D-Link users are also reporting compatibility problems. Microsoft says they may update this in the Spring Dashboard update, but that won't be out for a couple months. For now either stay away from Apple's Extreme if you've got an Xbox 360 or hook it up via Ethernet.

Apple Support [Apple via TUAW]