First iPhone 2.0 Pwnage Tool Will Not Unlock iPhone 3G, says Dev TeamS

The tireless iPhone Dev folks who managed to jailbreak the iPhone 3G within five days of launch have announced that the first Pwnage tool will be released shortly, but it will not support a baseband unlock of the iPhone 3G. The team is still working out the particulars of the unlock and rightfully wants to do it correctly the first time. It will however jailbreak the 3G while maintaining App Store support and unlock your iPhone classic running the 2.0 firmware. [iPhone Dev Team Blog] Thanks Mehmet!