Apparently iPhone apps that need to have deeper access to the hardware, like Telenav's navigation, need a specific Verizon version in order to work. It might be due to differences between GSM vs. CDMA radios, or the GPS chip. [ZDNet]