Ditto. There is a *reason* I use an older browser. I installed waterfox but I was still willing to come back till this. It's an expired certificate on your end, it doesn't /need/ a new browser to be repaired. See ya firefox. After nearly ten years, I'm done.

— oommbackin5 (@oommbackinfive) May 5, 2019