Jailbreak Now Available for iPhone OS 3.0, But Not for iPhone 3GSS

We knew this was coming, but it's good to know that hackers can still get into the iPhone OS so easily: PwnageTool for Mac OS X is now available for iPhone OS 3.0. Here are the details. [Updated]

• If you already have your iPhone jailbroken and unlocked, don't try to update your smartypanties phone to iPhone OS 3.0. PwnageTool won't unlock your iPhone. You have to wait until Ultrasnow is available for this.

• If you don't need the unlock but want to upgrade to iPhone OS 3.0, go ahead. After upgrading, jailbreak your iPhone with PwnageTool 3.0, and keep using Cydia and your non-official iPhone apps.

• If you have an iPhone 3GS, this won't work for you, so don't even try it.

And like always, use it at your own risk. Update: I downloaded and tried it. It works. [Torrent file]