Snow Leopard Will Not Support PowerPCs After All

It looks like our initial source was mistaken because the Snow Leopard developer preview build contains a document stating that it's compatible with Intel only. Sorry PowerPC. But even if Apple were to release a Snow Leopard for the aging platform, there's no way that developers could take advantage of the software's real assets-multi-core optimization. As for our original source, they explain, "There were still updated PPC drivers [in the build I saw], though, so *shrug*. I'd say that indicates that it must've been a decision made late in the development process." [Logiciel Mac via MacRumors]